AVA Studio ID

lisensi

Iklan

AVA Studio
30 December 2022, 10:12 WITA (GMT+8)
Last Updated 2022-12-30T06:44:03Z

Script MikroTik RouterOS - Auto Fix SNTP and Clock for Indonesia Timezone

Advertisement
Script MikroTik RouterOS - Auto Fix SNTP and Clock for Indonesia Timezone

Time is very important for your computer to do the right thing. If your watch is off by one minute, your authenticator app will not work. Wrong hour by hour, there is a problem with windows networking. If the date is incorrect, you risk your SSL certificate expiring earlier (or later) than expected. Your VPN may not work. Dates in logs are misleading. Wrong time in general is a bad thing, and even worse is a time when the access point is out of sync with the access point's billing. Because timeliness is very important.

Manual Setup:
#============================================== 
# Auto Repair TimeZone and clock By AVA Studio ID
#============================================== 
# (WIB) Waktu Indonesia Barat  = +07:00 
# (WITA) Waktu Indonesia Tengah = +08:00 
# (WIT) Waktu Indonesia Timur = +09:00 
#============================================== 
# Ganti "+7:00" sesuaikan dengan daerah anda
#============================================== 
/system clock manual set time-zone="+07:00"; 
/system clock set time-zone-autodetec=no; 
/system clock set time-zone-name="manual"; 
/ip cloud set update-time=no; :local ntpServer "asia.pool.ntp.org"; :local primary [resolve $ntpServer]; :local secondary [resolve $ntpServer]; 
/system ntp client set primary-ntp $primary; 
/system ntp client set secondary-ntp $secondary; 
/system ntp client set enabled=yes;
Completed Script With Scheduler
/system scheduler add interval=1d name=SETTING-TIMEZONE on-event="
#=============================\ =================\r\ 
# Auto Repair TimeZone and clock By AVA STudio ID\r\ 
#==============================================\r\ 
# WIB || Waktu Indonesia Barat = +07:00\r\ 
# WITA || Waktu Indonesia Tengah = +08:00\r\ 
# WIT || Waktu Indonesia Timur (= +09:00 \r\ 
#==============================================\r\ 
# Ganti \"+07:00\" sesuaikan dengan daerah anda\r\ 
#==============================================\r\ 
/system clock manual set time-zone=\"+07:00\";\r\ 
/system clock set time-zone-autodetec=no;\r\ 
/system clock set time-zone-name=\"manual\";\r\ /ip cloud set update-time=no;\r\ 
:local ntpServer \"asia.pool.ntp.org\";\r\ 
:local primary [resolve \$ntpServer];\r\ 
:local secondary [resolve \$ntpServer];\r\ 
/system ntp client set primary-ntp \$primary;\r\ 
/system ntp client set secondary-ntp \$secondary;\r\ 
/system ntp client set enabled=yes;" policy=\ 
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-time=startup

No comments:

Post a Comment

Selamat Datang

X
X